Damn you, Indecision!

Bug with Mail.app on the iPhone?

I think I may have stumbled upon a bug when sending an e-mail from an
iPhone where there is text at the top followed by a picture, and then
more text. It seems that all of the text added below a picture is
basically thrown away.

I first noticed this when I e-mailed a blog post to Posterous a while
ago with a screenshot in the middle of the entry. I just chalked it up
to some random mistake, either user error because I had posted really
late at night, or perhaps some error with Posterous (though that’s
clearly not the case, looking back).

Well, today I had taken a screenshot of a shopping list and sent it to
the hubby since I’m stuck at home sick, and it had one item that was
truncated. I explained what the truncated item was below the
screenshot, as well as some additional info unrelated to the list. The
hubby just called to ask about the truncated item, and I told him what
it was, but also said that I had explained what the item was below the
screenshot. Then he asked a couple other questions that I actually had
addressed in the rest of the e-mail, and I realized that this might
actually be a problem with Mail.app. I just looked at the mail in my
Sent mail folder, and the e-mail doesn’t have any of the text I added
under the picture.

Has anyone else noticed this issue? Not sure if I should somehow
submit this as a bug report to Apple, with only two examples that I
know of.

Advertisements

4 responses

  1. Hi Jezlyn

    I haven’t noticed text below an image going missing but I have in the past found that any text below an image comes through as an attachment with the missing text in it. The only time I have noticed this happen is when I’ve sent a photo to my works exchange account. I’ll have to investigate this further using different accounts.

    October 17, 2009 at 3:47 am

    • Interesting, I’ll have to ask the hubby if the e-mail I sent has an attachment with the missing text… Let me know if you find out anything further!

      October 17, 2009 at 4:53 pm

  2. I tested with an email to Blogger and found the same thing. Text typed above the photo made it. Text below did not.

    October 19, 2009 at 7:08 am

  3. andy

    I have had similar problems occur many times, the the problem seems to have changed a little recently.

    Originally I was saving draft emails and when I would come back to edit and sent them they would just be missing, or the latest change I made gone. Lately I’ve had problems with the email not actually getting sent and just vanishing. I know I pressed send and everything seemed normal, but the recipient doesn’t receive the mail and it is not in the sent mail folder.

    I have no idea why this kind of thing keeps happening to me, but it’s driving me batty. I hope apple fix this problem soon (along with all the other iphone bugs)

    November 13, 2009 at 9:54 am

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s