Damn you, Indecision!

Damn pictures in WordPress…

Pffff. If you visit my blog and notice missing pictures, please post something in the comment thread for that entry. Sometimes when I post from Windows Live Writer, the pictures don’t display properly. I try to tweak the HTML code if I notice a problem, and sometimes it fixes the problem. The weird thing is that I can view the blog post just fine from my computer, but if I try another computer, it still has missing pictures. And if I just refresh the page (on my computer or others), sometimes just doing that will fix the problem, other times it won’t. 😛

I really don’t like posting via WordPress.com’s web interface (which I’m doing right now), and I prefer to use Windows Live Writer because of its ink blogging capabilities. I realize that Windows Live Writer has some funky HTML output, but I feel like WordPress should be flexible enough to take the input from WLW, since other blogs do fine with it. *sigh* I know there are other offline editors out there, but they don’t really work for me, for one reason or another. And none of the others have an ink blogging capability, which is important to me, even though it’s been quite a while since I’ve ink blogged.

Anyway, just venting. I’m fairly sure that WordPress won’t fix this, judging from the replies on their support forums regarding Windows Live Writer, so I’m just going to have to deal with it. It’s a shame, since I think WordPress is a lot nicer than most of the other free blogging services out there. I’d happily pay a subscription fee (within reason) if WordPress would just fix their finicky HTML rendering. I’d consider hosting my own WordPress blog, but I don’t think that would fix the problem, since it would still be a WordPress blog…or would it?

Advertisements

4 responses

  1. Where did someone say we weren’t going to fix problems with Live Writer? We’re working on the bug now.

    October 23, 2006 at 1:07 am

  2. Thanks for the update, Matt. Sorry about the overexaggeration; I was posting under the influence of frustration. It’s just that when I first went searching for possible fixes for this issue in the support forum (found this thread back then: http://wordpress.com/forums/topic.php?id=3577&replies=15#post-25264), it seemed like the main answer was to use something else, or get around the FTPing or whatever by hotlinking to some photos uploaded elsewhere. Granted this was a while ago, when Windows Live Writer was newly released. I hadn’t tried to search the support forums again since then.

    I’m glad that this issue is getting looked at. It’s more likely that WordPress would fix the issue to be compatible with WLW, rather than Microsoft changing how WLW generates HTML or uploads files.

    October 23, 2006 at 2:02 pm

  3. morebouncetotheounce

    i’m suffering the same issue. it seems as though sometimes the image is there and then with a refresh it dissapears. almost like the file has gone onto one server, but not all of them. eventually it all catches up with itself a couple of days later though.

    November 25, 2006 at 10:42 am

  4. ok, so where’s the solution? I have been looking ever since 2.1.x came out and broke Livewriter’s image uploads

    May 12, 2007 at 1:02 pm

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s